`
joe_zxy
  • 浏览: 43384 次
  • 性别: Icon_minigender_1
  • 来自: 深圳
最近访客 更多访客>>
社区版块
存档分类
最新评论

POJ ACM习题【No.2000】

    博客分类:
  • ACM
 
阅读更多
Gold Coins
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 10469 Accepted: 6505

Description

The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of the next two days (the second and third days of service), the knight receives two gold coins. On each of the next three days (the fourth, fifth, and sixth days of service), the knight receives three gold coins. On each of the next four days (the seventh, eighth, ninth, and tenth days of service), the knight receives four gold coins. This pattern of payments will continue indefinitely: after receiving N gold coins on each of N consecutive days, the knight will receive N+1 gold coins on each of the next N+1 consecutive days, where N is any positive integer.

Your program will determine the total number of gold coins paid to the knight in any given number of days (starting from Day 1).

Input

The input contains at least one, but no more than 21 lines. Each line of the input file (except the last one) contains data for one test case of the problem, consisting of exactly one integer (in the range 1..10000), representing the number of days. The end of the input is signaled by a line containing the number 0.

Output

There is exactly one line of output for each test case. This line contains the number of days from the corresponding line of input, followed by one blank space and the total number of gold coins paid to the knight in the given number of days, starting with Day 1.

Sample Input

10
6
7
11
15
16
100
10000
1000
21
22
0

Sample Output

10 30
6 14
7 18
11 35
15 55
16 61
100 945
10000 942820
1000 29820
21 91
22 98

 

本题的关键是在于设置一个递增的Factor,过N个数字之后,将Factor调整成N+1。

 

 

import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		
		while(true)
		{
			int day = Integer.valueOf(cin.nextLine()).intValue();
			if(day == 0)
				break;
			
			System.out.println(day + " " + getTotalCoin(day));
		}
	}
	
	private static int getTotalCoin(int day)
	{
		int total = 1;
		int factor = 2;
		int index = 0;
		
		if(day == 1)
			return 1;
		
		for(int i = 2; i <= day; i++)
		{
			if(index == factor)
			{
				index = 0;
				factor ++;
			}
			
			total += factor;
			index ++;
		}	
		return total;
	}
}
 
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics