`
joe_zxy
  • 浏览: 43152 次
  • 性别: Icon_minigender_1
  • 来自: 深圳
最近访客 更多访客>>
社区版块
存档分类
最新评论

POJ ACM习题【No.2140】

    博客分类:
  • ACM
阅读更多
Herd Sums
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8376 Accepted: 5027

Description

The cows in farmer John's herd are numbered and branded with consecutive integers from 1 to N (1 <= N <= 10,000,000). When the cows come to the barn for milking, they always come in sequential order from 1 to N.

Farmer John, who majored in mathematics in college and loves numbers, often looks for patterns. He has noticed that when he has exactly 15 cows in his herd, there are precisely four ways that the numbers on any set of one or more consecutive cows can add up to 15 (the same as the total number of cows). They are: 15, 7+8, 4+5+6, and 1+2+3+4+5.

When the number of cows in the herd is 10, the number of ways he can sum consecutive cows and get 10 drops to 2: namely 1+2+3+4 and 10.

Write a program that will compute the number of ways farmer John can sum the numbers on consecutive cows to equal N. Do not use precomputation to solve this problem.

Input

* Line 1: A single integer: N

Output

* Line 1: A single integer that is the number of ways consecutive cow brands can sum to N.

Sample Input

15

Sample Output

4

 

可以从中间进行查找,Index = Num/2+1

 

import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		
		while(cin.hasNext())
		{
			int num = cin.nextInt();
			int ways = 1;
			
			int index = num/2+1;
			
			for(int i = index; i > 1; i--)
			{
				int tmpNum = i;
				for(int j = i - 1; j > 0; j--)
				{
					tmpNum += j;
					if(tmpNum == num)
					{
						ways++;
						break;
					}else if(tmpNum > num)
						break;
				}
			}
			System.out.println(ways);
			
			
		}

	}

}
 

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics