`
joe_zxy
  • 浏览: 43246 次
  • 性别: Icon_minigender_1
  • 来自: 深圳
最近访客 更多访客>>
社区版块
存档分类
最新评论

POJ ACM习题【No.3157】

    博客分类:
  • ACM
阅读更多
Java vs C++
Time Limit: 2000MS
Memory Limit: 65536K
Total Submissions: 3966
Accepted: 1103

Description

Apologists of Java and C++ can argue for hours proving each other that their programming language is the best one. Java people will tell that their programs are clearer and less prone to errors, while C++ people will laugh at their inability to instantiate an array of generics or tell them that their programs are slow and have long source code.

Another issue that Java and C++ people could never agree on is identifier naming. In Java a multiword identifier is constructed in the following manner: the first word is written starting from the small letter, and the following ones are written starting from the capital letter, no separators are used. All other letters are small. Examples of a Java identifier are javaIdentifier , longAndMnemonicIdentifier , name , nEERC .

Unlike them, C++ people use only small letters in their identifiers. To separate words they use underscore character ‘_ ’. Examples of C++ identifiers are c_identifier , long_and_mnemonic_identifier , name (you see that when there is just one word Java and C++ people agree), n_e_e_r_c .

You are writing a translator that is intended to translate C++ programs to Java and vice versa. Of course, identifiers in the translated program must be formatted due to its language rules — otherwise people will never like your translator.

The first thing you would like to write is an identifier translation routine. Given an identifier, it would detect whether it is Java identifier or C++ identifier and translate it to another dialect. If it is neither, then your routine should report an error. Translation must preserve the order of words and must only change the case of letters and/or add/remove underscores.

Input

The input file consists of one line that contains an identifier. It consists of letters of the English alphabet and underscores. Its length does not exceed 100.

Output

If the input identifier is Java identifier, output its C++ version. If it is C++ identifier, output its Java version. If it is none, output “Error!

instead.

Sample Input

sample input #1

long_and_mnemonic_identifier

sample input #2

anotherExample

sample input #3

i

sample input #4

bad_Style

Sample Output

sample output #1

longAndMnemonicIdentifier

sample output #2

another_example

sample output #3

i

sample output #4

Error!

 

需要注意的:

1)黑体字不是输入输出;

2)必须小写字母开头

3)不能有连续_

4)字符串最后不能是_

 

 

import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		
		while(cin.hasNext())
		{
			String str = cin.nextLine();
	
			int type = checkType(str);
			if(type == -1)
				System.out.println("Error!");
			else if(type == 1)
			{
				StringBuffer sb = new StringBuffer();
				while(str.indexOf("_") != -1)
				{
					int index = str.indexOf("_");
					sb.append(str.substring(0, index));
					if(index != 0)
					{
						String tmp = str.substring(index+1);
						str = FUpper(tmp);
					}else
						str = str.substring(index+1);
					
				}
				sb.append(str);
				System.out.println(sb.toString());
			}
			else if(type == 2)
			{
				StringBuffer sb = new StringBuffer();
				for(int i = 0; i < str.length(); i++)
				{
					char c = str.charAt(i);
					if(c >= 97 && c <= 122)
					{
						sb.append(c);
					}else if(c >= 65 && c <= 90)
					{
						sb.append('_');
						sb.append((char)(c+32));
					}
				}
				System.out.println(sb.toString());
			}
				
		}

	}
	
	private static String FUpper(String str)
	{
		StringBuffer sb = new StringBuffer();
		
		sb.append((char)(str.charAt(0) - 32));
		if(str.length() > 1)
			sb.append(str.substring(1));
		return sb.toString();
	}
	
	private static int checkType(String str)
	{
		if(str.endsWith("_"))
			return -1;
		if(str.startsWith("_"))
			return -1;
		
		if(str.indexOf("_") != -1)
		{			
			for(int i = 0; i < str.length(); i++)
			{
				if((str.charAt(i) + 0) >= 65 && (str.charAt(i) + 0) <= 90)
					return -1;
				if(str.charAt(i) == '_' && i != 0 && i != str.length()-1)
					if(str.charAt(i-1) == '_' || str.charAt(i+1) == '_')
						return -1;
			}
			
			return 1;
		}
	
		if(str.charAt(0) >= 65 && str.charAt(0) <= 90)
			return -1;

		return 2;
	}
}
 
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics