`
joe_zxy
  • 浏览: 43468 次
  • 性别: Icon_minigender_1
  • 来自: 深圳
最近访客 更多访客>>
社区版块
存档分类
最新评论

POJ ACM习题【No.2039】

    博客分类:
  • ACM
阅读更多
To and Fro
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 4405 Accepted: 2906

Description

Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is "There’s no place like home on a snowy night" and there are five columns, Mo would write down
t o i o y

h p k n n

e l e a i

r a h s g

e c o n h

s e m o t

n l e w x

Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character "x" to pad the message out to make a rectangle, although he could have used any letter.

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

toioynnkpheleaigshareconhtomesnlewx

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.

Input

There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

Output

Each input set should generate one line of output, giving the original plaintext message, with no spaces.

Sample Input

5
toioynnkpheleaigshareconhtomesnlewx
3
ttyohhieneesiaabss
0

Sample Output

theresnoplacelikehomeonasnowynightx
thisistheeasyoneab

 

此题需要注意的就是设置一个控制左右方向的Flag标志位

 

 

import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		
		int num = 0;
		String str;
		char[][] array;
		while(true)
		{
			num = Integer.valueOf(cin.nextLine()).intValue();
			if(num == 0)
				break;
			else
			{
				str = cin.nextLine();
				array = convert(str, num);
				System.out.println(getRawStr(array));
			}
		}
	}
	
	private static char[][] convert(String str, int col)
	{		
		int toRight = 1;
		
		int row = 0;
		if(str.length()%col == 0)
			row = str.length()/col;
		else
			row = str.length()/col + 1;
		
		char[][] array = new char[col][row];
		
		int index = 0;
		for(int i = 0; i < row; i++)
		{
			if(toRight % 2 == 1)
				for(int j = 0; j < col; j++)
					array[j][i] = str.charAt(index++);
			else
				for(int j = col-1; j >= 0; j--)
					array[j][i] = str.charAt(index++);
			
			toRight++;
		}
		
		return array;
	}
	
	private static String getRawStr(char[][] array)
	{
		StringBuffer sb = new StringBuffer();
		for(int i = 0; i < array.length; i++)
			for(int j = 0; j < array[0].length; j++)
				sb.append(array[i][j]);
		return sb.toString();
	}
}
 
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics