`
joe_zxy
  • 浏览: 43385 次
  • 性别: Icon_minigender_1
  • 来自: 深圳
最近访客 更多访客>>
社区版块
存档分类
最新评论

POJ ACM习题【No.1503】

    博客分类:
  • ACM
Go 
阅读更多
Integer Inquiry
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10648 Accepted: 4161

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670

 

再次无耻

 

import java.util.*;
import java.math.*;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		
		BigDecimal bd1 = BigDecimal.valueOf(0);
		BigDecimal bd2 = BigDecimal.valueOf(0);
		String str;
		
		while(cin.hasNext())
		{
			str = cin.nextLine();
			if(str.equals("0"))
				break;
			else
			{
				bd2 = new BigDecimal(str);
				bd1 = bd1.add(bd2);
			}
		}
		
		System.out.println(bd1.toPlainString());
		

	}

}
 

 

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics