`
joe_zxy
  • 浏览: 43360 次
  • 性别: Icon_minigender_1
  • 来自: 深圳
最近访客 更多访客>>
社区版块
存档分类
最新评论

POJ ACM习题【No.2845】

    博客分类:
  • ACM
阅读更多
01000001
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5770 Accepted: 1858

Description

Adding binary numbers is a very simple task, and very similar to the longhand addition of decimal numbers. As with decimal numbers, you start by adding the bits (digits) one column at a time, from right to left. Unlike decimal addition, there is little to memorize in the way of rules for the addition of binary bits:

   0 + 0 = 0
   1 + 0 = 1
   0 + 1 = 1
   1 + 1 = 10
   1 + 1 + 1 = 11

Just as with decimal addition, when the sum in one column is a two-bit (two-digit) number, the least significant figure is written as part of the total sum and the most significant figure is “carried” to the next left column. Consider the following examples:

                       11  1 <-- Carry bits --> 1   11
  1001101             1001001                    1000111
+ 0010010           + 0011001                  + 1010110
 --------           ---------                  ---------
  1011111             1100010                   10011101

The addition problem on the left did not require any bits to be carried, since the sum of bits in each column was either 1 or 0, not 10 or 11. In the other two problems, there definitely were bits to be carried, but the process of addition is still quite simple.

Input

The first line of input contains an integer N , (1 ≤ N ≤ 1000 ), which is the number of binary addition problems that follow. Each problem appears on a single line containing two binary values separated by a single space character. The maximum length of each binary value is 80 bits (binary digits). Note: The maximum length result could be 81 bits (binary digits).

Output

For each binary addition problem, print the problem number, a space, and the binary result of the addition. Extra leading zeroes must be omitted.

Sample Input

3
1001101 10010
1001001 11001
1000111 1010110

Sample Output

1 1011111
2 1100010
3 10011101

 

 

 

 

import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		
		int pnum = Integer.valueOf(cin.nextLine()).intValue();
		
		for(int i = 1; i <= pnum; i++)
		{
			String[] str = cin.nextLine().split(" ");
			String a = removePreZero(str[0]);
			String b = removePreZero(str[1]);
			
			a = reverse(a);
			b = reverse(b);
			
			String result = addBinary(a, b);
			result = reverse(result);
			result = removePreZero(result);
			System.out.println(i + " " + result);
		}

	}
	
	private static String addBinary(String a, String b)
	{
		StringBuffer sb = new StringBuffer();
		int loa = a.length();
		int lob = b.length();
		
		String newa = a;
		String newb = b;
		if(loa > lob)
		{
			newa += "0";
			for(int i = 0; i <= (loa-lob);i++)
				newb += "0";
		}else if(loa == lob)
		{
			newa += "0";
			newb += "0";
		}else
		{
			newb += "0";
			for(int i = 0; i <= (lob-loa);i++)
				newa += "0";
		}
		
		int carry = 0;
	
		for(int i = 0; i < newa.length(); i++)
		{
			char c1 = newa.charAt(i);
			char c2 = newb.charAt(i);
			int tmp = c1 + c2 - 96 + carry;
			if(tmp == 0)
			{
				sb.append('0');
				carry = 0;
			}else if(tmp == 1)
			{
				sb.append('1');
				carry = 0;
			}else if(tmp == 2)
			{
				sb.append('0');
				carry = 1;
			}else
			{
				sb.append('1');
				carry = 1;
			}
		}
		
		return sb.toString();
	}
	
	private static String reverse(String str)
	{
		StringBuffer sb = new StringBuffer();
		
		for(int i = str.length() - 1; i >= 0; i--)
		{
			sb.append(str.charAt(i));
		}
		
		return sb.toString();
		
	}
	
	private static String removePreZero(String str)
	{
		int index = 0;
		
		while(index < str.length())
		{
			if(str.charAt(index) == '0')
				index++;
			else
				break;
		}
		
		if(index == str.length())
			return "0";
		
		return str.substring(index);
	}

}
 
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics